TechTip: DB2 Web Query and Excel Spreadsheets: Easy as Pie! Part Il

Did you know DB2 Web Query has output options to send your reports directly to Excel? Learn about some of
the tool's features that will help you easily and quickly build Excel spreadsheets.

Written by Gene Cobb

In part 1 of this series, TechTip: DB2 Web Query and Excel Spreadsheets: Easy as Pie!, Part |, | provided an
introduction on the basic DB2 Web Query output options to Excel spreadsheets. In this TechTip, | expand upon
those capabilities and show you how to take advantage of Excel's multiple worksheet capability by using the
following DB2 Web Query features: table of contents and compound documents.

Table of Contents

In the previous TechTip, we activated features such as Sort Across and Stack Measures to pack quite a bit of
information into the spreadsheet. The sample output of that spreadsheet is shown in Figure 1.

| 4] A B | c | D | E F G H |

1 Country
2 i Canada France Germany Spain United States

KMl Product Type  Product Category Product Name

4 | Audio Amplifiers/PreAmps/Tuners  AM / FM Sterso Tuner Quantity 339 n 302 218 3,548
5 Returns 31 37 29 20 344
6 Revenue 567,461.00 §73,829.00 560,098.00 543,382.00 $706,052.00
i Cost of Goods Sold 533,500.00 537,100.00 5$30,200.00 521,800.00 5354,800.00
8 Profit 533,561 536,729 529,898 521,582 5351,252
9 |Audio Amplifiers/PreAmps/Tuners  Modular Components Series Preamp 5.1 Quantity 1,953 904 800 502 11,822
10 Returns 187 B89 79 49 1,210
11| Revenue 5779,247.00 5360,696.00 5319,200.00 5200,298.00 54,716,978.00
12 Cost of Goods Sold §644,490.00 5298,320.00 5264,000.00 5165,660.00 53,901,260.00
13 Profit 5134,757 562,376 555,200 534,638 5815,718
14 Audio Amplifiers/PreAmps/Tuners  PA4000 Sterso & Surround Power Amplifier Quantity 1,780 528 715 385 11,864
15| Returns 17z 52 68 36 1,237
16| §532,220.00 5157,872.00 5213,785.00 5115,115.00 53,547,336.00
17| 5391,600.00 $116,160.00 5157,300.00 584,700.00 52,610,080.00
18] 5140,620 541,712 556,485 530,415 5937,256
19 .Audiu Amplifiers/PreAmps/Tuners  Power Amplifier 3,220 1,058 1,251 1,159 17,877
20 315 102 122 10 2,001
21 5801,780.00 5263,442.00 5311,499.00 5288,591.00 54,451,373.00
22 5579,600.00 5190,440.00 5225,180.00 5208,620.00 53,217,860.00
23| 5222,180 573,002 586,319 579,571 §1,233,513
24| Audio Amplifiers/PreAmps/Tuners  PreAmp/Tuner Two 5,763 2,100 3,074 2,836 35,053
26| 561 20z 299 e 3,728
26| 52,875,737.00 51,047,%00.00 51,533,926.00 51,415,164.00 517,491,447.00
27 $1,440,750.00 $525,000.00 5768,500.00 $709,000.00 58,763,250.00
28 51,434,987 522,300 §765,426 ST06,164 58,728,157
29 |Audio Audio Systems Home Theater Surround System 782 118 200 269 7,524
30 75 1 20 25 738
31| 5781,218.00 §117,882.00 5199,800.00 5268,731.00 57,516,476.00
32| 5586,500.00 588,500.00 5150,000.00 5201,750.00 55,643,000.00
33| 5194,718 529,382 549,800 566,981 51,873,476
34 |Audio Audio Systems Home Theater 5.1 System 4,879 1,%63 2,357 1,513 27,144
35 4an 189 278 148 2,922
36 5$9,753,121.00 53,924,037.00 54,711,643.00 53,024,487.00 554,260,856.00
3r Cost of Goods Sold 56,342,700.00 52,551,900.00 53,064,100.00 51,966,500.00 535,287,200.00
38| Profit 53,410,421 51,372,137 51,647,543 51,057,587 518,973,656

Figure 1: This spreadsheet shows an example of Sort Across and Stack Measures.

While this spreadsheet may meet all of the original report requirements, it's a lengthy report and there simply
may be too much information for some users to digest. They might prefer to have the information broken into
multiple worksheets—one for each product type. Such a feature is easily activated by turning on the Table of
Contents feature under the Format tab.

When Table of Contents is activated, a separate worksheet for each unique value of the report's primary (first)
Sort By column is created. Each worksheet contains the data for that particular Sort By column, and its tab is
labeled with the appropriate Sort By field value. To activate Table of Contents, click the Format tab in
InfoAssist, expand the Navigation group, and select Table of Contents icon. When activated, the icon is
illuminated. An example is shown in Figure 2.
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Figure 2 : Find the Table of Contents icon.
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An example report is shown in Figure 3.
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Bl Product Type  Product Category Product Name i
4 | Audio Amplifiers/PreAmps/Tuners  AM / FM Stereo Tuner 339 m 302 218 3,548 E
5| 3 37 5 0 344
[ 567,461.00 573,829.00 560,098.00 543,382.00 5706,052.00 ||
7 $33,900.00 $37,100.00 $30,200.00 521,800.00 5354,800.00
8| 533,561 536,729 529,898 521,582 5351,252
9 .Aud\‘o Amplifiers/PreAmps/Tuners  Modular Components Series Preamp 5.1 1,953 904 800 502 11,822
10 187 BY 79 49 1,210
" $779,247.00 5360,696.00 $319,200.00 5200,298.00 54,716,976.00
12 5644,430.00 5298,320.00 5264,000.00 5165,660.00 53,301,260.00
13 §134,757 562,376 55,200 534,638 815,718
14 | Audio Amplifiers/PreAmps/Tuners  PA4000 Stereo & Surround Power Amplifier 1,780 528 715 385 11,864
15 17 52 68 36 1,237
16| 5$532,220.00 5157,872.00 5213,785.00 5115,115.00 53,547,336.00
17 5$391,600.00 5116,160.00 $157,300.00 584,700.00 $2,610,080.00
18 5140,620 541,712 556,485 530,415 $937,256
19 Audio Amplifiers/PreAmps/Tuners  Power Amplifier 3,220 1,058 1,251 1,159 17,877
20| 315 102 122 110 2,001
2| $801,780.00 5263,442.00 $311,499.00 5288,591.00 54,451,373.00
22 5579,600.00 5190,440.00 5225,180.00 5208,620.00 $3,217,860.00
23 5222,180 $73,002 586,319 579,971 51,233,513
24 | Audio Amplifiers/PreAmps/Tuners  PreAmp/Tuner Two 5,763 2,100 3,074 2,836 35,053
25 561 202 %9 276 3,728
26| ever 52,875,737.00 $1,047,900.00 §1,533,926.00 §1,415,164.00 §17,491,447.00
27 Cost of Goods Sold 51,440,750.00 5525,000.00 5768,500.00 5709,000.00 58,763,250.00
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Figure 3: Here's an example of the report with Table of Contents.

Notice there are now five seprate worksheets, one for each unique Product Type. Simply click on the tab to
display the worksheet for that particular product type. This effectively "splits up" the large report into separate
smaller reports, but all the data is still together in a single spreadsheet!

Note: Table of Contents exhibits different behavior based on the report's specified output format. For example,
if HTML or Active Reports is selected, an interactive dialog window is presented so that end users can select a
Sort By field value and immediately "jump" to the first occurrence of that value in the report. This is especially
useful for large HTML reports with many rows of data.

Compound Documents

The Table of Contents feature is very useful, but as mentioned, it's splitting up the results of a single report
execution into multiple worksheets. What if you actually want to combine the results of different DB2 Web
Query reports into one spreadsheet and have the results of each individual report appear in a separate
worksheet? Is it possible to do this with DB2 Web Query? The answer is "Absolutely!"

In DB2 Web Query, you can combine multiple reports and/or charts into a single report. The result is referred to
as a compound document (sometimes called a compound report), and the report developer can choose from a
variety of output formats, such as PDF, HTML, Active Reports, and Excel Spreadsheets. If Excel is chosen, the
result of each individual report and chart execution appears on a separate worksheet.

To create a compound document, right-click on the folder in which you wish to place the document and select
Document, as shown in Figure 4.
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Cirl+x
Crl+C

Cri+v

DEL

Folder

Report
Chart
Dashboard

InfoAssist is launched and presents a list of data sources (DB2 Web Query synonyms) on which to base the
various reports and charts in the compound document. Select the desired synonym from this list.

The default output format for compound documents is PDF. So the first thing we want to do is change it to
Excel. From the Home tab, click on the PDF icon and select Excel from the drop-down list, as shown in Figure

5.
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Figure 5: Change the document to Excelouput format.

Now you're ready to insert multiple reports and/or charts. To do this, select the Insert tab, as shown in Figure 6.
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Figure 6: Select the Insert tab.

From this tab, you can create new reports or charts and insert them into the compound document. If you have
existing reports or charts that you would like to insert, you can do that as well. In my finished example shown in
Figure 7, | have inserted three different reports into my compound document.
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Home Insert Format Data  Slicers  Layout View  Field

Detail Summary Join Advanced Missing Data Switch
_ (Defire) (Compuls) Filter
Calculation Join Filter Display Data Source
_ o=t /% Document
El Quantity -
Bl Revenus \E| Product Category Product Name Quantity Revenue
B Cost of Goods Sold
A et Amplifiers/ PreAmps/Tuners AM / FM Stereo Tuner 13 52,587.00
B Warranty Expenses PA4000 Stereo & Surround Power Amplifier m 5110,929.00
B Shipping, Cost Powser Amplifier 3058 575,945.00
B Quantity,In Stock PreAmp/Tuner Two 136 5167,664.00
B Price s Audio Systems Home Theater 5.1 System 187 5373,813.00
Home Theater 7.1 THX System 537 51,610,463.00
— Y Filter Micro Hifi Stereo System 1 §39.00
Micro 5.1 System 92 545,908.00
D Players and Recorders CD Changer / CD Player 53 510,547.00
Store Order Actual
Name Date Ship Date DaysToShip
ABC Electronics 201311017 2013/11/22 36
2013/12/01 45
= 2013712112 56
1By 2013/12/19 &
2014/02/07 113
0131112 2013712114 2
2014/01/01 50
2014/01/08 57
2014/01/2% 78
Plant Country Plant Region Plant State Plant Name  Quantity Returns ReturnsPercentage
United States Mew England Massachusettes Boston 7,437 mn 9.56%
Pacific California Loz Angeles 8o7 29 28.38%
Washington Seattle 1,631 5% 5.75%
South Atlantic Florida Orlando 607 57 9.39%
West North Central Mizzouri Saint Louis 3,657 348 9.52%
West South Central Texas Dallas 5,775 553 9.58%

Figure 7: There are three reports in this example compound document.

Now when you save and run this report, Excel is launched and the compound document is presented in the
spreadsheet. Notice in Figure 8, Figure 9, and Figure 10 that each individual report appears in a separate
worksheet.



E
Il |Product Category Product Name Quantity
| 2 |Amplifiers/PreAmps/Tuners AM / FM Stereo Tuner 4,778 5950,822.00
3 Modular Components Seres Preamp 5.1 15,981  56,376,419.00
4 PA4000 Stereo & Surround Power Amplifier 15,272 54,566,328.00
g Power Amplifier 24,565  56,116,685.00
G PreAmp/Tuner Two 48,826  524,364,174.00
7 |Audio Systems Home Theater Surround System 8,893  58,884,107.00
8 Home Theater 5.1 System 37,856  575,674,144.00
9 Home Theater 7.1 THX Swstem 8,103 524,300,897.00
il 10 Micro HiFi Stereo System 20,663  58,244,537.00
4 11 Micro 5.1 System 10,505  55,241,995.00
W 12 |CD Players and Recorders  CD Changer / CD Player 23,563 54,68%,037.00
il 13 CD Recorder with 50GE Hard Cisc Drive 7,245 55,788,755.00
14 Digital CD Turntable 47,443 52%9,666,958.00
15 Multichannel Super Audio CD Player 4,782  59,559,218.00
16 400 Disc Super Audio CD Changer 4,60%  54,143,491.00
17 |Digital Cameras EasyShot Digital Camera 101,588  523,263,652.00
18 EasyShot Digital Camera 6.1 Megapixel 131,937 590,%04,5%3.00
:: 19 EasyShot Digital Camera B Megapixel 42,952 538,613,848.00
20 EasyShot Ultra Zoom Digital Camera 61,003  518,84%,927.00
| 21 EasyShot Wide Zoom Digital Camera 46,363 512,471,647.00
] 272 |Digitald Camcorders Digitald Easycam Camcorder 14x Power Zoom 15,560  53,563,240.00
23 DigitalB Easycam Camcorder 16x Power Zoom 8,236  51,9%68,404.00
Product Revenue Report Store Days to Ship Report Plant Returns Percentage Report

Figure 8: This example compound document shows worksheet 1.



2 2 Actual
) 1 : Ship Date DaysToShip
| 2 [ABC Electronics 2012/01/16 2012/02/01 16
{3 2012/02/03 18
{4 2012/03/10 54
15 2012/03/12 56
16 2012/03/16 60
7 2012/02/13 2012/03/10 26
8 2012/03/19 35
g 2012/03/21 37
10 2012/03/23 39
1 39
12 2012/03/24 40
13 2012/03/26 42
14 2012/04/02 49
15 2012/04/05 52
16 2012/04/07 54
17 2012/04/14 61
18 2012/05/28 105
19 2012/02/14 2012/03/21 3
20 2012/03/22 37
21 7
22 2012/03/25 40
23 2012/03/28 43
24 2012/03/31 46

Product Revenue Report Store Days to Ship Report Plant Returns Percentage Report

- & _________________________________________________________________________________________|
Figure 9: This example compound document shows worksheet 2.
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(M Plant Country Plant Region Plant State Plant Hame Quantity Returns ReturnsPercentage
2 |United States Mew England Maszachusettes Boston 1,275,843 123,134 9.66%
3 Pacific California Los Angeles 165,755 28,521 17.21%
4 Washington Seattle 97,242 9,390 9.66%
) South Atlantic Flarida Orlandao 213,405 20,445 9.58%
6 West Morth Central Mizsouri Saint Louis 333,143 31,765 9.53%
7 West South Central Texas Dallas 201,193 19,383 9.63%
3

9

Product Revenue Report Store Days to Ship Report Plant Returns Percentage Report

'Figure 10: This example compound document shows worksheet 3.

Summary

By utilizing Excel's ability to have multiple worksheets in a single spreadsheet, you can split up and logically
segment the results of a single report execution or you can combine multiple DB2 Web Query reports into one
spreadsheet. Bringing these two technologies together means you can deliver the kinds of reports your users
want and let them "take it from there."



In my next article in this series, | will introduce you to two additional Excel output options: Excel Formula and
Excel Pivot. These formats have unique characteristics that you may find quite useful when trying to satisfy the
reporting requirements of your end users!



